Symptoms

When you try to export a report, the export fails with the following error:

Export failed: Database logon failed.: Database logon failed.

Possible Causes

This error message is reported from the Crystal Reports runtime engine that Report Commander uses, and unfortunately can have many different causes:

  • Check for an obvious problem first: make sure you have specified the correct user ID and password on the command line or in your project file.
  • If you are using a connection that uses integrated Windows security, make sure you are running Report Commander under a user account that has permission to connect to the database.
  • If you are using an ODBC connection, be sure the alias is configured correctly (see article  K00000351).
  • For connections to Microsoft Access databases, see article K00000236.
  • Make sure the necessary database driver is installed on the computer where Report Commander is running. For example, this error may occur if you do not have the SQL Server Native Client installed.
    • Be sure the version of the driver installed is compatible with the database server.
    • Be sure the "bitness" (32-bit or 64-bit) of the driver matches the Report Commander version you have installed.