Symptoms

When printing or exporting a report using Report Commander, Report Commander fails with an error similar to the following:

Error: Failed to export report: Logon failed.
Error in File C:\Temp\{F3471536-AB59-4A9F-8828-C2D421D26C9C}.rpt:
Unable to connect: incorrect log on parameters.

Cause

This error may occur if:

  1. You have not specified the database login credentials required for the report, or the credentials you have entered are incorrect.
  2. The database driver required for the report has not been installed on the computer where Report Commander is running.

Resolution

1. Ensure that you are providing the correct login parameters.

For each listed database connection, click the Edit button and enter the necessary information.

2. Ensure the necessary database driver is installed on the computer where Report Commander is running. For example, if your report uses any of these database drivers, you need to install the driver on the computer:

  • Oracle
  • Microsoft SQL Server Native Client
  • Microsoft OLE DB Driver for SQL Server (MSOLEDBSQL)
  • MySQL

Be sure the install the correct version of the driver for the database server you are connecting to, and the right bitness (32- or 64-bit), based on which version of Report Commander you have installed (the 32-bit version of Report Commander, requires 32-bit drivers; the 64-bit version requires 64-bit drivers).