Symptoms

Report Commander has been working correctly but begins failing with an error message similar to the following:

Report Commander has encountered a problem and needs to close. We are sorry for the inconvenience.

This problem may appear after Windows updates are installed, or after another program is installed or removed.

Cause

This problem may occur if an update to Windows or to another program corrupts the installation for Report Commander, the Crystal Reports runtime components, or the Microsoft .NET Framework.

Resolution

This problem can generally be resolved by repairing the Report Commander installation. This can be done through "Add/Remove Programs" or "Programs and Features" in the Windows Control Panel.

If Repair does not resolve the problem, or the Repair fails to run correctly, try uninstalling and reinstalling Report Commander. After you remove Report Commander, check the Report Commander program directory (generally "c:\program files\arcana development\report commander" or "c:\program files (x86)\arcana  development\report commander") and be sure that no .exe or .dll files were left behind (delete them if there are any).

If you no longer have the Report Commander setup program (or if the version you have is older than the current version), you can download the current version from the Report Commander download page.

Uninstalling and reinstalling will not affect your Report Commander license.