Symptoms

When a job is sent to an Agent for execution, the job remains in "Waiting for agent" status for longer than expected and then fails with status "Execution failed." execution fails and the Job Log shows error 5192:

Remote Agent agentname returned an error while processing a command. The command will not be retried. Error: An error occurred on the server while processing the request. Please contact Technical Support for assistance.

Additional Information

The adTempus server diagnostic log will contain lines with the following error information:

Error during request processing
System.Security.Cryptography.CryptographicException: Bad Data.

Cause

This error occurs because the Agent encounters a problem while trying to decrypt data sent from the Master/Controller.

Resolution

Status

  • adTempus 4
    This issue has been resolved. Resolved in version 4.10.2.

  • adTempus 5
    This issue has been resolved. Resolved in version 5.0.6.