Symptoms

When connecting to a database server with TLS 1.0 and 1.1 disabled, the adTempus service or one of the database tools (Database Configuration Wizard or Database Utility) reports the following error:

Cannot connect to the database server: A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - An existing connection was forcibly closed by the remote host.)

Cause

This happens if you do not have version 4.6 or later of the Microsoft .NET Framework installed on the computer where the adTempus service is installed. adTempus uses the SQL Server database client that is part of the .NET Framework, and TLS 1.2 is not supported on older versions of the .NET Framework.

Resolution

Download and install the latest version of the Microsoft .NET Framework from the Microsoft download site. Be sure to install the ".NET Framework Runtime", not ".NET Core".

More Information

To determine which version of the .NET Framework you have installed, refer to this article.

Status

  • adTempus 4

  • adTempus 5