Symptoms

When the computer where the adTempus Console is running is using IPV6, the Console connection to the adTempus server (whether local or remote) may fail frequently (e.g., every 30 seconds) with message ADT000040E:

The connection to server "servername" has been lost

Cause

Each time the Console sends a request to the adTempus server, the server validates that the request is coming from a valid client session. As part of this validation, the server checks to make sure the call is coming from the same IP address that originally established the connection. If the addresses don't match, the call is rejected, and the Console reports that the connection has been lost.

IPV6 defines a set of privacy extensions for Internet addressing, and Windows turns these extensions on by default. With this configuration, the IP address that your computer uses for outbound connections is generated randomly and changes frequently (more information). When the address changes, subsequent calls to the adTempus server appear to be coming from a different computer, so the server rejects the request.

Workaround

The next update to adTempus will include an option to disable IP address verification for client sessions. Until then, the only workaround for this problem is to disable the IPV6 privacy extensions on the computer where the Console is being run. To do so, use the Run as Administrator option to open a command prompt, and run this command:

netsh int ipv6 set privacy disabled

Then restart the adTempus Console.

Status

  • adTempus 4
    This issue has been resolved. Resolved in version 4.2.