Symptoms

When you run the adTempus database installation and configuration wizard (adtdbconfig.exe), either directly or as part of installation, the wizard fails with the following error:

An error has occurred: Access to the registry key 'HKEY_LOCAL_MACHINE\SOFTWARE\Arcana Development\adTempus\Database' is denied.

Cause

This error occurs if your user account does not have permission to create/modify the Registry key named in the error message. If you are an Administrator, this error may occur if you do not use the "Run as Administrator" option when launching adtdbconfig.

Resolution

If the database configuration tool was launched automatically as part of installation, there is no need to uninstall/reinstall the software. Locate the "adtdbconfig.exe" program in the adTempus "database" directory (e.g., "C:\Program Files\Arcana Development\adTempus\Database") and run it using the "Run as Administrator" option.

This failure occurs after the configuration wizard has already created your adTempus database. When you rerun the database configuration wizard, you can de-select the options to create the database; you only need the wizard to create the Registry entries for you.

Note: If you configured adTempus to use a local or remote standalone SQL Server instance (rather than the default local SQL Server Express) using SQL Server authentication, the configuration tool has created a database user for adTempus, and generated a random password for that account. Since the password was never written to the Registry, there is no way to retrieve it. The simplest solution in this case is to delete both the new adTempus database and the adTempus logon that the tool created. Then rerun adtdbconfig to recreate the database and the logon.

Status

The database configuration tool has been corrected for the next adTempus release so that Windows will always prompt for elevation (run as Administrator) when running the tool.