Symptoms

When a user attempts to manually run a job in the adTempus Console, following error message is displayed after the user selects the "Run" command from the menu:

An unexpected error has occurred: System.Runtime.InteropServices.COMException (0xC000A41C): You do not have permission to perform the requested action.

After the user clicks the OK button in the error dialog, the adTempus Console terminates.

Cause

This error occurs if the user attempting to run the job does not have View permission for the Queue to which the job is assigned.

Resolution

To resolve this problem, a user with the necessary authority (e.g., a member of the Administrators securiyt group) must grant the user View permission to the Queue.

In practice it is generally simpler to grant all users View access to all queues. Doing this only gives the users the ability to see the queues; access to jobs within the queues is still controlled separately by job and group security settings.

To assign permissions for all queues:

  1. Right-click the Queues node in the adTempus Console, then select the Queue security command.
  2. In the Security Properties window, click the Add button and add "Users".
  3. With the "Users" item selected, check the box to allow View permission.

Note: Be sure the "Apply Permissions To" option is set to "Queues, jobs" to allow the settings to propagate to all queues. This option is labeled incorrectly in the Console, and does not actually cause permissions to be inherited by jobs in the queue.

Status

This issue was corrected in adTempus 3.0.7, released on November 22, 2009. See article K00000361 for information about obtaining this update.