Symptoms

The adTempus service fails to start as described in article K00000222. The adTempus diagnostic log contains a line with the following error message:

Cannot open database requested in login 'adtempus_XXX'. Login fails.

Cause

This error indicates that the database name specified in the adTempus configuration is incorrect.

Resolution

Correct the database connection information being used by adTempus.

adTempus 3

This information is found under Registry key "HKEY_LOCAL_MACHINE\Software\Arcana Development\adTempus\Database". The ConnectionString value under this Registry key contains a segment that specifies the database name:

database=adtempus_XXX

Be sure the database name ("adtempus_XXX" in this example) is correct.

adTempus 4 and later

This information is found under Registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Arcana Development\adTempus\instances\Default\Database". The Database value under this Registry key specifies the name of the database to use.