Symptoms

When you click OK in the Program Properties window after adding or modifying a scheduled program, the Schedule Administrator returns the following error message:

An error occurred while saving the schedule: ?? (13)

(The "??" characters in the message above represent "garbled" characters that may appear in the error message.)

Cause

There are two common causes for this problem:

  • The disk on which the Arcana Scheduler is installed has run out of disk space. This prevents the Arcana Scheduler from saving the configuration file for the scheduled program.
  • The Arcana Scheduler configuration files have been made read-only, or the Arcana Scheduler does not have permission to modify them. Check the "schedules\1" subdirectory under the Arcana Scheduler program directory. The files must not be read-only, and the SYSTEM account must have full access to the directory and its contents.

If neither of these circumstances is causing the problem, or if the Arcana Scheduler services stops ("crashes") when the error occurs, please contact us for assistance.