SSL - Negotiation - Authentication failed because the remote party has closed the transport stream.

jb_bryant (23 posts)
February 11, 2021 04:04 PM
Accepted Answer

This may be trivial but I can't figure out why some emails aren't working for my process.

I'm running the command line script from a batch file with about 200 individual executions - each passing a crystal report .pdf to a seperate recipient. 

Some instances work successfully and others don't. 

The email server I'm referencing is a relay for MS365 <clientsdomain>-com.mail.protection.outlook.com:25 (no authentication)

Issue started after the relay...

Does the message below mean the recipient requires higher security/whitelisting?

 

See error log example:

2021-02-11 12:20:04    Error    Send e-mail with subject "Transmission Detail for XYZ COMPANY - Wednesday": E-mail message send failed: IOException occurred during SSL negotiation. InnerException message follows: Authentication failed because the remote party has closed the transport stream.: Authentication failed because the remote party has closed the transport stream.
Bill Staff (602 posts)
February 12, 2021 01:31 PM
Accepted Answer

That's weird. If they're all connecting to the same server I would expect them all to fail. Are the connections possibly going through a load balancer and getting sent to different servers?

We've seen that error in some other cases, caused by our mail client still supporting older SSL protocols (but again, I'd expect it to fail every time). We have a fix for that that hasn't been released yet; open a support case and I'll get the update to you to try.

Bill Staff (602 posts)
March 1, 2021 03:36 PM
Accepted Answer
We never heard anything further from you on this. If you want to try the update I mentioned, it's now available in the latest hotfix release.
jb_bryant (23 posts)
March 4, 2021 09:06 AM
Accepted Answer
Bill wrote:
We never heard anything further from you on this. If you want to try the update I mentioned, it's now available in the latest hotfix release.

Thanks. I'll give it a try. Sorry I didn't respond earlier.

Replies are disabled for this topic.