Symptoms

When you run the adTempus Database Configuration Wizard or Database Utility, the tool fails to connect to the database server, with the follow error:

Cannot connect to the database server:[DBNETLIB][ConnectionOpen (SECDoClientHandshake()).]SSL Security Error

Cause

This error occurs if you have disabled TLS 1.0 on the database server. It happens because these tools use the OLEDB database driver to connect to the database, and this driver does not support newer TLS protocols.

Note that the adTempus service is unaffected, because it uses a different database driver.

Workaround

This problem is resolved beginning with version 4.6. If you are using version 4.5.1, a software update is available to resolve this problem: Download adTempus_K00000562.zip, which contains updated versions of the Database Configuration Wizard (adtdbconfig) and the Database Utility (adtdbutil). After downloading, unzip the files from the ZIP into the adTempus program folder (e.g., "C:\Program Files\Arcana Development\adTempus\4.0"), replacing the existing versions of the files.

If you are encountering this issue during adTempus installation

  1. Cancel the database configuration wizard and allow the rest of the setup process to complete. The adTempus software will remain installed.
  2. Update the adTempus program folder with the new utilities as described above.
  3. Run the Database Configuration Wizard (available in the adTempus > Server Tools group on the Start menu, or by running "adtdbconfig.exe" directly).
  4. Follow the instructions in the database wizard to complete database setup.
  5. Start the adTempus service. adTempus is now ready for use.

To work around this issue you can also temporarily enable TLS 1.0 for the database server while you complete database setup. Once you have completed the initial setup, you can disable TLS 1.0 again, as the adTempus service itself does not experience this problem.

Related Issues

You will also need to update to the latest version of the Microsoft .NET Framework if you currently have a version older than 4.6 installed on the computer. See article K00000579 for more information.

Status

  • adTempus 4
    This issue has been resolved. Resolved in version 4.6.