Symptoms

When you try to start the adTempus Console or one of the adTempus tools (License Manager, Database Utility, Database Configuration Wizard, etc.), the application fails immediately with an error reporting window indicating that "[Program Name] has encountered an problem". If you attempt to continue past this message, you may get the error "Configuration system failed to initialize."

After you acknowledge these messages, the program closes.

The problem may also prevent the adTempus service from starting, or from operating properly.

Cause

This problem happens if another application (generally an installer) has corrupted the machine-wide configuration file (machine.config) for the .NET Framework. This issue will affect adTempus and most other programs that depend on the .NET Framework.

In most of the cases we have seen, the problem appears to be caused by installation of DB2 drivers from DataDirect.

Resolution

To resolve this problem you must correct the problems with the machine.config file (found at "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\Machine.Config").

If you are familiar with the syntax and use of the file, you can attempt to correct the problem yourself or contact the vendor who provided the software that corrupted the file.

Otherwise you will need to contact us for assistance. Before you open a support case, use the option to submit the error report to us, as the error report will have additional details about what is wrong with the file. You should also include the machine.config file when you open your support case.