Unanswered Topic Audit change log empty RSS Feed Icon

You must be logged in to reply to this topic.

Avatar
Joined: September 6, 2016
Posts: 2
 

Hi, 

We have recently upgraded to your 4.3 release and we noticed that when we generate the report for the change log there are no entries after 24 hours (This is the time frame we have been testing). This happens even if we run the report for the entire month. 

A contributing reason for our upgrade was to solve this exact problem we were facing with a previous version (4.1).

 

Please do advise if you may know if we are possibly doing something wrong?

 

Regards 

 
Avatar
Arcana Development Staff
Joined: November 6, 2015
Posts: 329
 

Is this the same problem described here?

Please check the Auditing and Snapshots settings in the Server Options window (Configuration > General Server Options). How long is it set to retain audit records for?

If you select the job in the Console and look at the Change Log tab at the bottom of the window, are the changes listed there?

 
Avatar
Joined: September 6, 2016
Posts: 2
 

Hi 

I have updated these settings and I seem to have the data showing in the Object change log as long as "keep forever" is unchecked ans the days are increased to 999.

 

 
Avatar
Arcana Development Staff
Joined: November 6, 2015
Posts: 329
 

I have confirmed there is a bug when you use the "Keep forever" setting. This is mistakenly being treated as no retention, so the records are deleted within 24 hours.

There will be a fix in the next release, or you can open a support case to get a hotfix when it is available. Otherwise, using an explicit retention period as you have done should work.

 
You must log in to post.